Why are words split in odd places in posts?

Submitted by Brian Nystrom on Sat, 05/26/2018 - 08:32

For some reason, I see a lot of words at the ends of lines in posts are split with one letter "ophaned" at the end or beginning of a line. It makes reading posts tedious. Is there any way to eliminate this?

This irritates me too. Always looking back at the previous line to figure out the word. Another thing that is irritating me, and I may not be accessing content in the correct manner here but, under the "Recent comments" column the current first 7 posts are all on the same thread, Instead of falling under the original thread title they are all titled by whatever the first few words of the reply are. Makes it difficult for me to have any idea which threads I have read and which I haven't. 

Hopefully, this will be the biggest 'problem' I have this week :)

For some reason the default styling of the theme for comments is set to 

word-break: break-all; 

Which makes it so line breaks happen as soon as the line of text reaches a certain width regardless of whether it is in the middle of a word or not.

I had changed this a while back, but then I updated the theme to the latest version and it reverted back. I'll fix it eventually but I want to do it in such a way that it will stay fixed after future updates.

JayBabina

Mon, 05/28/2018 - 12:27

I looked up the user preferences early on and found nothing. Since this was posted I went on the Dupral site and its an acknowledged problem (lots of complaints) and there were a few patches but in HTML and a bit complex and also some info blaming various browsers for the problem. When I first noticed it, I was going to ask others if they had that or was it my Safari/Mac browser but then I tried Firefox with the same results. Apparently there's no magic button setting in Dupral to stop it.

Since most (all?) browsers allow you to load custom CSS styles for accessibility, this issue with the theme could be overridden from the client. In theory, anyway. 

However you enter custom CSS for your browser, try the following: 

.comment__content {word-break: normal !important;}

This would be overridden on any website you visit, but hardly anywhere is this CSS declaration going to be used, and if it is used for a reason, it probably will not be in an element class "comment_content". 

Maybe that helps someone. 

They split on Firefox, Chrome, Vivaldi and Brave. Four browsers so obviously Dupral is not a good discussion engine. I've never seen it happen on any other discussion forum.

I just checked it with the above, and I'm seeing line splits in the middle of words. I still believe it is a simple CSS issue.

If I right-click a comment, select "Inspect", I can view the definition for .comment__content. Down at the bottom is "word-break: break-all; " If I un-check the checkbox next to it, the problem goes away. 

The only reason other forums don't have the problem is they don't have the same style definition. I will get around to making the style change permanently, but I haven't had the time yet.

BTW, I have no idea why the style is set that way, seems like a bad idea, but someone must have liked how it looked for some application.